[Solved] VMware View Composer update failed with error “database cannot be found or a connection cannot be established”

Follow below steps to resolve error “The database cannot be found or a connection cannot be established. Check the DSN name to ensure that it is correctly entered” when upgrading VMware View Composer 6.2.3 or later failed due to incompatible Microsoft .Net Framework.

Install .NET framework 4.6.1

Step 1: Download .NET framework 4.6.1 from Microsoft Download Center
Download Microsoft .NET Framework 4.6.1 (Web Installer) for Windows 7 SP1, Windows 8, Windows 8.1, Windows 10, Windows Server 2008 R2 SP1, Windows Server 2012 and Windows Server 2012 R2
Download Microsoft .NET Framework 4.6.1 (Offline Installer) for Windows 7 SP1, Windows 8, Windows 8.1, Windows 10, Windows Server 2008 R2 SP1, Windows Server 2012 and Windows Server 2012 R2

Step 2: Upgrade Microsoft .NET framework to version 4.6.1.

Step 3: Restart the machine.

Step 4: Run installation/upgrade for VMware View Composer.

Reference

VMware Knowledge Base: Upgrading View Composer fails with the error: “database cannot be found or connection cannot be established” (2147517)