Skip to Content

MC407050: Retirement of Exchange Online PowerShell with MFA

We will be retiring “the Exchange Online PowerShell module with MFA” on December 31, 2022. Support for the Module will end on August 31, 2022.

MC407050: Retirement of Exchange Online PowerShell with MFA

We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication and supports accounts with or without MFA.

Key points

  • Timing:
    • End of support: August 31, 2022
    • Retirement: December 31, 2022
  • Action: Update to the latest version of V2 Module

How this will affect your organization

If you are still using the “the Exchange Online PowerShell module with MFA”, (described in this document – V1 module – Connect to Exchange Online PowerShell using MFA we recommend that you move to the latest GA version of V2 Module (v2.0.5) to avoid a situation where you need service or support that is no longer available after 31 Aug 2022.

What you need to do to prepare

We recommend using the Exchange Online PowerShell V2 module (EXO V2 module), which uses modern authentication and supports accounts with or without MFA.

For installation and connection instructions, see Install and maintain the EXO V2 module and Connect to Exchange Online PowerShell.

For more information about the different versions of Exchange Online PowerShell modules, see Understanding the Different Versions of Exchange Online PowerShell Modules and Basic Auth.

Message ID: MC407050
Published: 29 July 2022
Updated: 01 August 2022
Action required by: 31 December 2022
Platform: Online, World tenant

    Ads Blocker Image Powered by Code Help Pro

    Ads Blocker Detected!!!

    This site depends on revenue from ad impressions to survive. If you find this site valuable, please consider disabling your ad blocker.