RealPlayer Security Vulnerabilities fixed by version 14.0.6

RealNetworks announced some vulnerabilities in RealPlayer which can be exploited by cracker to compromise a user’s system. Below list out all identified vulnerabilities and fixed in RealPlayer version 14.0.6.


1. CVE-2011-2952: RealPlayer Dialog Box Use After Free Vulnerability
Use after free error exists in pngu3267.dll within the handling of displayed dialog boxes when navigating away from a web page. This can be exploited to dereference already freed memory by tricking a user into visiting a specially crafted web page and e.g. display the “Copyrights” or “Version Info” dialog box via the “About RealPlayer” context menu or open the “About This Presentation” dialog box. Successful exploitation of this vulnerability allows execution of arbitrary code.

2. CVE-2011-2945: RealPlayer SIPR Heap Buffer Overflow Vulnerability
Unspecified error related to SIPR can be exploited to cause a heap-based buffer overflow.

3. CVE-2011-2946: RealPlayer ActiveX Remote Code Execution Vulnerability
Unspecified error related to the RealPlayer ActiveX control can be exploited to execute arbitrary code.

4. CVE-2011-2947: RealPlayer Cross-Zone Scripting Remote Code Execution Vulnerability
Application allows the processing of local HTML files with scripting enabled, which can be exploited to execute arbitrary code by e.g. tricking a user into visiting a malicious website.

5. CVE-2011-2948: RealPlayer SWF DefineFont Remote Code Execution Vulnerability
Error within the handling of “DEFINEFONT” fields when parsing Flash files can be exploited to cause a memory corruption.

6. CVE-2011-2949: RealPlayer MP3 ID3 tags Remote Code Execution Vulnerability
Boundary error within the handling of certain ID3v2 tags in MP3 files can be exploited to cause a heap-based buffer overflow.

7. CVE-2011-2950: RealPlayer QCP Parsing Remote Code Execution Vulnerability
Boundary error within qcpfformat.dll when handling certain QCP media files can be exploited to cause a heap-based buffer overflow.

8. CVE-2011-2951: RealPlayer Advanced Audio Coding Element Remote Code Execution Vulnerability
Error within the parsing of AAC raw_data_frame elements can be exploited to cause a buffer overflow.

9. CVE-2011-2953: RealPlayer ActiveX Browser Plugin Out of Bounds Vulnerability
Unspecified “Out of Bounds” error exists within RealPlayer ActiveX control

10. CVE-2011-2954: RealPlayer Embedded AutoUpdate Use After Free Vulnerability
Unspecified use-after-free error related to “Embedded AutoUpdate” exists within RealPlayer ActiveX control.

11. CVE-2011-2955: RealPlayer Embedded Modal Dialog Use After Free Vulnerability
Unspecified use-after-free error related to “Embedded Modal Dialog” exists within RealPlayer ActiveX control.

The vulnerabilities are reported in versions 14.0.0 through 14.0.5. Other versions may also be affected.

via RealNetworks